请选择 进入手机版 | 继续访问电脑版

【五行系列】五行主图学前B 买点涨停突破类指标

[复制链接]
open 发表于 2020-10-17 13:28:21 | 显示全部楼层 |阅读模式




指标很简单,就是主图上的买卖信号,这是破解后五行学前主图B,后续还是H,正式版。

源码如下:

{公式名称: 五行主图学前B
公式描述:
无参数
公式类型: 技术指标公式-其他类型
画线方法: 主图叠加
公式版本: 0
显示小数: 缺省位数
坐标线位置: 自动
额外Y轴分界: 无

参数精灵:无
用法注释:无
公式源码:}


  1. X_1:=IF(DATE<1201030,1,0);
  2. X_2:=MA(CLOSE,3);
  3. X_3:=MA(CLOSE,5);
  4. X_4:=MA(CLOSE,10);
  5. X_5:=MA(CLOSE,20);
  6. X_6:=MA(CLOSE,30);
  7. X_7:=MA(CLOSE,60);
  8. X_8:=CLOSE<X_3 AND X_3<X_4 AND X_4<X_5 AND X_5<X_7;
  9. X_9:=INBLOCK(1);
  10. X_10:=INBLOCK(2);
  11. X_11:=CLOSE/REF(CLOSE,1)>1.097 AND OPEN=CLOSE AND CLOSE=HIGH;
  12. X_12:=IF(INBLOCK(2),0.2,IF(INBLOCK(1) AND IF(DATE<1200824,1,0),0.2,0.1));
  13. X_13:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_12) AND CLOSE=HIGH;
  14. X_14:=CLOSE<=DTPRICE(REF(CLOSE,1),X_12) AND CLOSE=LOW;
  15. X_15:=HIGH/REF(CLOSE,1)>1.095 AND HIGH/REF(CLOSE,1)<1.101 AND CLOSE<HIGH AND (X_9!=1 AND X_10!=1);
  16. DRAWICON(X_15 AND X_1,HIGH+0.2,14),COLORRED;
  17. X_16:=HIGH/REF(CLOSE,1)>1.095 AND HIGH/REF(CLOSE,1)<1.101 AND CLOSE<HIGH AND (X_9=1 AND IF(DATE<1200824,1,0));
  18. DRAWICON(X_16 AND X_1,HIGH+0.2,14),COLORRED;
  19. X_17:=HIGH/REF(CLOSE,1)>1.195 AND HIGH/REF(CLOSE,1)<1.201 AND CLOSE<HIGH AND REF(CLOSE,10)>1;
  20. DRAWICON(X_17 AND X_1,HIGH+0.2,14),COLORRED;
  21. X_18:=X_13 AND CLOSE=OPEN AND LOW<CLOSE;
  22. DRAWICON(X_18 AND X_1,HIGH+0.2,13),COLORRED;
  23. X_19:=IF(PERIOD=1,48,IF(PERIOD=2,16,IF(PERIOD=3,8,IF(PERIOD=4,4,1))));
  24. X_20:=VOL/REF(VOL,X_19);
  25. X_21:=TOPRANGE(VOL);
  26. X_22:=LOWRANGE(VOL);
  27. 实二:IF(CLOSE<REF(CLOSE,1),(OPEN+CLOSE)/2,(OPEN+CLOSE)/2),NODRAW,COLORBLUE;
  28. 虚二:IF(CLOSE<REF(CLOSE,1),(HIGH+LOW)/2,(HIGH+LOW)/2),NODRAW,COLORBLUE;
  29. 三一:IF(CLOSE<REF(CLOSE,1),OPEN-(OPEN-CLOSE)/3,CLOSE+(OPEN-CLOSE)/3),NODRAW,COLORBLUE;
  30. 三二:IF(CLOSE<REF(CLOSE,1),OPEN-(OPEN-CLOSE)*2/3,CLOSE+(OPEN-CLOSE)*2/3),NODRAW,COLORBLUE;
  31. 高:HIGH,NODRAW,COLORBLACK;
  32. 低:LOW,NODRAW,COLORBLACK;
  33. 开:OPEN,NODRAW,COLORBLACK;
  34. 收:CLOSE,NODRAW,COLORBLACK;
  35. 人:SUM(AMOUNT,1)/SUM(VOL,1)/100,NODRAW;
  36. 振:(HIGH-LOW)/LOW*100,NODRAW,COLORBLUE;
  37. 枪:(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100,NODRAW,COLORBLUE;
  38. 腿:(MIN(CLOSE,OPEN)-LOW)/LOW*100,NODRAW,COLORBLUE;
  39. 乖五:(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100,NODRAW,COLORBLUE;
  40. X_23:=IF(HIGH/LOW>1.04 AND CLOSE/OPEN>1.04,CLOSE,MIN(HIGH,CLOSE));
  41. X_24:=IF(HIGH/LOW>1.04 AND CLOSE/REF(CLOSE,1)>1.04,实二,MAX(LOW,OPEN));
  42. X_25:=IF(HIGH/LOW>1.04 AND OPEN/CLOSE>1.04,实二,MIN(HIGH,OPEN));
  43. X_26:=IF(HIGH/LOW>1.04 AND OPEN/CLOSE>1.04,OPEN,MIN(LOW,OPEN));
  44. X_27:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,2)>REF(CLOSE,3) AND REF(CLOSE,3)>REF(CLOSE,4) AND REF(CLOSE,1)/REF(OPEN,4)>1.08;
  45. X_28:=人>REF(人,1) AND REF(人,1)>REF(人,2) AND REF(人,2)>REF(人,3);
  46. X_29:=IF(CLOSE>OPEN,X_23,X_25);
  47. X_30:=IF(CLOSE>OPEN,X_24,X_26);
  48. X_31:=(OPEN+CLOSE)/2;
  49. X_32:=CLOSE>REF(CLOSE,1) AND X_20>1.78 AND X_20<3;
  50. X_33:=CLOSE<REF(CLOSE,1) AND X_20>1.78 AND X_20<4;
  51. X_34:=CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1);
  52. X_35:=X_34 AND REF(X_34,1) AND REF(X_34,2) AND OPEN>REF(OPEN,1);
  53. X_36:=HIGH/REF(LOW,10)<1.2 AND CLOSE/OPEN>1.043 AND CLOSE/OPEN<1.095 AND CLOSE/人<1.04 AND 人/REF(CLOSE,1)>1.02 AND CLOSE-OPEN>OPEN-LOW AND (HIGH-CLOSE)/CLOSE<0.03 AND (OPEN-LOW)/LOW<0.02 AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1);
  54. STICKLINE(X_36 AND X_1,OPEN,CLOSE,(-1),0),COLOR6B238E;
  55. STICKLINE(X_36 AND X_1,HIGH,LOW,0,0),COLOR6B238E;
  56. X_37:=HIGH/REF(LOW,10)<1.3 AND (COUNT(OPEN>REF(CLOSE,1),4)<4 AND COUNT(CLOSE>REF(CLOSE,1),4)<4) AND CLOSE/OPEN>1.043 AND CLOSE/OPEN<1.195 AND CLOSE/人<1.14 AND 人/REF(CLOSE,1)>1.05 AND (OPEN-LOW)/LOW<0.02 AND VOL>REF(VOL,1) AND (X_9=1 OR X_10=1);
  57. STICKLINE(X_37 AND X_1,OPEN,CLOSE,(-1),0),COLOR6B238E;
  58. STICKLINE(X_37 AND X_1,HIGH,LOW,0,0),COLOR6B238E;
  59. STICKLINE(X_13,OPEN,CLOSE,(-1),0),COLORMAGENTA;
  60. STICKLINE(X_13,HIGH,LOW,0,0),COLORMAGENTA;
  61. STICKLINE(X_14,OPEN,CLOSE,(-1),0),COLORBLACK;
  62. STICKLINE(X_14,HIGH,LOW,0,0),COLORBLACK;
  63. X_38:=(OPEN-CLOSE)/OPEN>0.02 AND CLOSE<REF(CLOSE,1);
  64. STICKLINE(X_38,(CLOSE+OPEN)/2,(CLOSE+OPEN)/2,2,1),COLORYELLOW;
  65. X_39:=(CLOSE-OPEN)/OPEN>0.03 AND CLOSE>REF(CLOSE,1);
  66. STICKLINE(X_39,(CLOSE+OPEN)/2,(CLOSE+OPEN)/2,2,1),COLORBLACK;
  67. X_40:=振>REF(振,1) AND VOL<REF(VOL,1) AND REF(CLOSE<REF(CLOSE,1),1);
  68. X_41:=5;
  69. X_42:=30;
  70. X_43:=100;
  71. GHA:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_41),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_41),1)+1)),DRAWNULL),COLORRED;
  72. GLA:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_41),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_41),1)+1)),DRAWNULL),COLORBLUE;
  73. GHB:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_42),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_42),1)+1)),DRAWNULL),DOTLINE,COLORRED;
  74. GLB:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_42),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_42),1)+1)),DRAWNULL),DOTLINE,COLORBLUE;
  75. GHC:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_43),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_43),1)+1)),DRAWNULL),DOTLINE,COLORRED;
  76. GLC:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_43),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_43),1)+1)),DRAWNULL),DOTLINE,COLORBLUE;
  77. X_44:=OPEN=LOW OR (OPEN-LOW<0.04 AND CLOSE/OPEN>1.05) AND X_11=0 AND CLOSE>REF(CLOSE,1);
  78. X_45:=OPEN-LOW=0.01 AND CLOSE>OPEN AND CLOSE/OPEN>1.02 AND COUNT(X_21>30,5)<1;
  79. X_46:=OPEN-LOW=0.02 AND CLOSE>OPEN AND (CLOSE/REF(CLOSE,1)>1.04 OR CLOSE/OPEN>1.035) AND COUNT(X_21>30,5)<1;
  80. X_47:=腿<0.1 AND CLOSE>OPEN AND CLOSE/REF(CLOSE,1)>1.04;
  81. X_48:=OPEN/REF(CLOSE,1)<1.03 AND CLOSE/REF(CLOSE,10)<1.2 AND CLOSE/REF(OPEN,5)<1.15 AND CLOSE/REF(CLOSE,10)<1.15 AND CLOSE/OPEN>1.01 AND HIGH-LOW>0.03 AND COUNT(X_27,3)<1 AND X_21<20 AND CLOSE/REF(40,CLOSE)<1.4;
  82. X_49:=X_48 AND (X_45 OR X_44) AND CLOSE>X_2 AND COUNT(X_44,4)<2 AND COUNT(CLOSE>OPEN,10)<8 AND COUNT(CLOSE>OPEN,6)<5 AND CLOSE/REF(CLOSE,3)<1.1 AND COUNT(人>REF(CLOSE,1),4)<3 AND HIGH-CLOSE>OPEN-LOW;
复制代码


游客,如果您要查看本帖隐藏内容请回复


回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则