请选择 进入手机版 | 继续访问电脑版

【五行系列】五行主图H 买点涨停突破类指标

[复制链接]
open 发表于 2020-10-17 13:36:01 | 显示全部楼层 |阅读模式
本帖最后由 open 于 2020-10-17 15:12 编辑



  1. {公式名称: 五行主图学前H
  2. 公式描述:
  3. 无参数
  4. 公式类型: 技术指标公式-其他类型
  5. 画线方法: 主图叠加
  6. 公式版本: 0
  7. 显示小数: 缺省位数
  8. 坐标线位置: 自动
  9. 额外Y轴分界: 无

  10. 参数精灵:无
  11. 用法注释:无
  12. 公式源码:}
  13. X_1:=IF(DATE<1201030,1,0);
  14. X_2:=MA(CLOSE,3);
  15. X_3:=MA(CLOSE,5);
  16. X_4:=MA(CLOSE,10);
  17. X_5:=MA(CLOSE,20);
  18. X_6:=MA(CLOSE,30);
  19. X_7:=MA(CLOSE,60);
  20. X_8:=CLOSE<X_3 AND X_3<X_4 AND X_4<X_5 AND X_5<X_7;
  21. X_9:=INBLOCK(1);
  22. X_10:=INBLOCK(2);
  23. X_11:=CLOSE/REF(CLOSE,1)>1.097 AND OPEN=CLOSE AND CLOSE=HIGH;
  24. X_12:=IF(INBLOCK(2),0.2,IF(INBLOCK(1) AND IF(DATE<1200824,1,0),0.2,0.1));
  25. X_13:=CLOSE>=ZTPRICE(REF(CLOSE,1),X_12) AND CLOSE=HIGH;
  26. X_14:=CLOSE<=DTPRICE(REF(CLOSE,1),X_12) AND CLOSE=LOW;
  27. X_15:=HIGH/REF(CLOSE,1)>1.095 AND HIGH/REF(CLOSE,1)<1.101 AND CLOSE<HIGH AND (X_9!=1 AND X_10!=1);
  28. DRAWICON(X_15 AND X_1,HIGH+0.2,14),COLORRED;
  29. X_16:=HIGH/REF(CLOSE,1)>1.095 AND HIGH/REF(CLOSE,1)<1.101 AND CLOSE<HIGH AND (X_9=1 AND IF(DATE<1200824,1,0));
  30. DRAWICON(X_16 AND X_1,HIGH+0.2,14),COLORRED;
  31. X_17:=HIGH/REF(CLOSE,1)>1.195 AND HIGH/REF(CLOSE,1)<1.201 AND CLOSE<HIGH AND REF(CLOSE,10)>1;
  32. DRAWICON(X_17 AND X_1,HIGH+0.2,14),COLORRED;
  33. X_18:=X_13 AND CLOSE=OPEN AND LOW<CLOSE;
  34. DRAWICON(X_18 AND X_1,HIGH+0.2,13),COLORRED;
  35. X_19:=IF(PERIOD=1,48,IF(PERIOD=2,16,IF(PERIOD=3,8,IF(PERIOD=4,4,1))));
  36. X_20:=VOL/REF(VOL,X_19);
  37. X_21:=TOPRANGE(VOL);
  38. X_22:=LOWRANGE(VOL);
  39. 实二:IF(CLOSE<REF(CLOSE,1),(OPEN+CLOSE)/2,(OPEN+CLOSE)/2),NODRAW,COLORWHITE;
  40. 虚二:IF(CLOSE<REF(CLOSE,1),(HIGH+LOW)/2,(HIGH+LOW)/2),NODRAW,COLORWHITE;
  41. 三一:IF(CLOSE<REF(CLOSE,1),OPEN-(OPEN-CLOSE)/3,CLOSE+(OPEN-CLOSE)/3),NODRAW,COLORWHITE;
  42. 三二:IF(CLOSE<REF(CLOSE,1),OPEN-(OPEN-CLOSE)*2/3,CLOSE+(OPEN-CLOSE)*2/3),NODRAW,COLORWHITE;
  43. 高:HIGH,NODRAW,COLORWHITE;
  44. 低:LOW,NODRAW,COLORWHITE;
  45. 开:OPEN,NODRAW,COLORWHITE;
  46. 收:CLOSE,NODRAW,COLORWHITE;
  47. 人:SUM(AMOUNT,1)/SUM(VOL,1)/100,NODRAW;
  48. 振:(HIGH-LOW)/LOW*100,NODRAW,COLORWHITE;
  49. 枪:(HIGH-MAX(CLOSE,OPEN))/MAX(CLOSE,OPEN)*100,NODRAW,COLORYELLOW;
  50. 腿:(MIN(CLOSE,OPEN)-LOW)/LOW*100,NODRAW,COLORYELLOW;
  51. 乖五:(CLOSE-MA(CLOSE,5))/MA(CLOSE,5)*100,NODRAW,COLORYELLOW;
  52. X_23:=IF(HIGH/LOW>1.04 AND CLOSE/OPEN>1.04,CLOSE,MIN(HIGH,CLOSE));
  53. X_24:=IF(HIGH/LOW>1.04 AND CLOSE/REF(CLOSE,1)>1.04,实二,MAX(LOW,OPEN));
  54. X_25:=IF(HIGH/LOW>1.04 AND OPEN/CLOSE>1.04,实二,MIN(HIGH,OPEN));
  55. X_26:=IF(HIGH/LOW>1.04 AND OPEN/CLOSE>1.04,OPEN,MIN(LOW,OPEN));
  56. X_27:=CLOSE>REF(CLOSE,1) AND REF(CLOSE,1)>REF(CLOSE,2) AND REF(CLOSE,2)>REF(CLOSE,3) AND REF(CLOSE,3)>REF(CLOSE,4) AND REF(CLOSE,1)/REF(OPEN,4)>1.08;
  57. X_28:=人>REF(人,1) AND REF(人,1)>REF(人,2) AND REF(人,2)>REF(人,3);
  58. X_29:=IF(CLOSE>OPEN,X_23,X_25);
  59. X_30:=IF(CLOSE>OPEN,X_24,X_26);
  60. X_31:=(OPEN+CLOSE)/2;
  61. X_32:=CLOSE>REF(CLOSE,1) AND X_20>1.78 AND X_20<3;
  62. X_33:=CLOSE<REF(CLOSE,1) AND X_20>1.78 AND X_20<4;
  63. X_34:=CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1);
  64. X_35:=X_34 AND REF(X_34,1) AND REF(X_34,2) AND OPEN>REF(OPEN,1);
  65. X_36:=HIGH/REF(LOW,10)<1.2 AND CLOSE/OPEN>1.043 AND CLOSE/OPEN<1.095 AND CLOSE/人<1.04 AND 人/REF(CLOSE,1)>1.02 AND CLOSE-OPEN>OPEN-LOW AND (HIGH-CLOSE)/CLOSE<0.03 AND (OPEN-LOW)/LOW<0.02 AND CLOSE>REF(CLOSE,1) AND VOL>REF(VOL,1);
  66. STICKLINE(X_36 AND X_1,OPEN,CLOSE,(-1),0),COLOR6B238E;
  67. STICKLINE(X_36 AND X_1,HIGH,LOW,0,0),COLOR6B238E;
  68. X_37:=HIGH/REF(LOW,10)<1.3 AND (COUNT(OPEN>REF(CLOSE,1),4)<4 AND COUNT(CLOSE>REF(CLOSE,1),4)<4) AND CLOSE/OPEN>1.043 AND CLOSE/OPEN<1.195 AND CLOSE/人<1.14 AND 人/REF(CLOSE,1)>1.05 AND (OPEN-LOW)/LOW<0.02 AND VOL>REF(VOL,1) AND (X_9=1 OR X_10=1);
  69. STICKLINE(X_37 AND X_1,OPEN,CLOSE,(-1),0),COLOR6B238E;
  70. STICKLINE(X_37 AND X_1,HIGH,LOW,0,0),COLOR6B238E;
  71. STICKLINE(X_13,OPEN,CLOSE,(-1),0),COLORMAGENTA;
  72. STICKLINE(X_13,HIGH,LOW,0,0),COLORMAGENTA;
  73. STICKLINE(X_14,OPEN,CLOSE,(-1),0),COLORWHITE;
  74. STICKLINE(X_14,HIGH,LOW,0,0),COLORWHITE;
  75. X_38:=(OPEN-CLOSE)/OPEN>0.02 AND CLOSE<REF(CLOSE,1);
  76. STICKLINE(X_38,(CLOSE+OPEN)/2,(CLOSE+OPEN)/2,2,1),COLORRED;
  77. X_39:=(CLOSE-OPEN)/OPEN>0.03 AND CLOSE>REF(CLOSE,1);
  78. STICKLINE(X_39,(CLOSE+OPEN)/2,(CLOSE+OPEN)/2,2,1),COLORYELLOW;
  79. X_40:=振>REF(振,1) AND VOL<REF(VOL,1) AND REF(CLOSE<REF(CLOSE,1),1);
  80. X_41:=5;
  81. X_42:=30;
  82. X_43:=100;
  83. GHA:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_41),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_41),1)+1)),DRAWNULL),COLORRED;
  84. GLA:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_41),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_41),1)+1)),DRAWNULL),COLORGREEN;
  85. GHB:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_42),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_42),1)+1)),DRAWNULL),COLORRED,LINETHICK2;
  86. GLB:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_42),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_42),1)+1)),DRAWNULL),COLORGREEN,LINETHICK2;
  87. GHC:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_43),1)+1)+1,CONST(REF(X_29,REF(HHVBARS(VOL,X_43),1)+1)),DRAWNULL),DOTLINE,COLORRED;
  88. GLC:IF(CURRBARSCOUNT<=CONST(REF(HHVBARS(VOL,X_43),1)+1)+1,CONST(REF(X_30,REF(HHVBARS(VOL,X_43),1)+1)),DRAWNULL),DOTLINE,COLORGREEN;
  89. X_44:=OPEN=LOW OR (OPEN-LOW<0.04 AND CLOSE/OPEN>1.05) AND X_11=0 AND CLOSE>REF(CLOSE,1);
  90. X_45:=OPEN-LOW=0.01 AND CLOSE>OPEN AND CLOSE/OPEN>1.02 AND COUNT(X_21>30,5)<1;
  91. X_46:=OPEN-LOW=0.02 AND CLOSE>OPEN AND (CLOSE/REF(CLOSE,1)>1.04 OR CLOSE/OPEN>1.035) AND COUNT(X_21>30,5)<1;
  92. X_47:=腿<0.1 AND CLOSE>OPEN AND CLOSE/REF(CLOSE,1)>1.04;
  93. X_48:=OPEN/REF(CLOSE,1)<1.03 AND CLOSE/REF(CLOSE,10)<1.2 AND CLOSE/REF(OPEN,5)<1.15 AND CLOSE/REF(CLOSE,10)<1.15 AND CLOSE/OPEN>1.01 AND HIGH-LOW>0.03 AND COUNT(X_27,3)<1 AND X_21<20 AND CLOSE/REF(40,CLOSE)<1.4;
  94. X_49:=X_48 AND (X_45 OR X_44) AND CLOSE>X_2 AND COUNT(X_44,4)<2 AND COUNT(CLOSE>OPEN,10)<8 AND COUNT(CLOSE>OPEN,6)<5 AND CLOSE/REF(CLOSE,3)<1.1 AND COUNT(人>REF(CLOSE,1),4)<3 AND HIGH-CLOSE>OPEN-LOW;
  95. X_50:=X_48 AND (X_45 OR X_44) AND X_13 AND CLOSE/REF(CLOSE,3)<1.15;
  96. X_51:=X_48 AND (X_45 OR X_44) AND OPEN<CLOSE AND OPEN<REF(CLOSE,1) AND VOL<REF(VOL,1) AND REF(HIGH,3)/OPEN>1.05;
  97. X_52:=X_48 AND (X_45 OR X_44) AND OPEN<CLOSE AND CLOSE>人 AND 人>REF(CLOSE,1) AND OPEN<REF(CLOSE,1) AND VOL>REF(VOL,1);
  98. X_53:=X_48 AND (X_46 OR X_44) AND CLOSE>人 AND 人>REF(CLOSE,1) AND VOL>REF(VOL,1) AND OPEN/REF(CLOSE,1)<1.03;
  99. X_54:=X_48 AND (X_45 OR X_44) AND 人>REF(CLOSE,1) AND REF(X_31,3)>REF(X_31,2) AND REF(X_31,2)>REF(X_31,1);
  100. X_55:=COUNT(CLOSE/OPEN>1.03,3)<1 AND REF(CLOSE,2)/REF(CLOSE,1)>1.02 AND REF(X_21>3,1);
复制代码


游客,如果您要查看本帖隐藏内容请回复


点击复制上面的代码,复制两段放在一起就可以了~~!
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则