请选择 进入手机版 | 继续访问电脑版

涨停潮A 某论坛上的金钻指标

[复制链接]
mem 发表于 2020-12-6 10:39:29 | 显示全部楼层 |阅读模式
  1. {公式名称: 涨停潮A
  2. 公式描述:
  3. 无参数
  4. 公式类型: 技术指标公式-其他类型
  5. 画线方法: 副图
  6. 公式版本: 0
  7. 显示小数: 缺省位数
  8. 坐标线位置: 自动
  9. 额外Y轴分界: 无

  10. 参数精灵:无
  11. 用法注释:无
  12. 公式源码:}
  13. X_1:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
  14. X_2:=(CLOSE-REF(CLOSE,2))/REF(CLOSE,2)*100;
  15. X_3:=(CLOSE-REF(CLOSE,3))/REF(CLOSE,3)*100;
  16. X_4:=(CLOSE-REF(CLOSE,4))/REF(CLOSE,4)*100;
  17. X_5:=(CLOSE-REF(CLOSE,5))/REF(CLOSE,5)*100;
  18. X_6:=(CLOSE-REF(CLOSE,6))/REF(CLOSE,6)*100;
  19. X_7:=(CLOSE-REF(CLOSE,7))/REF(CLOSE,7)*100;
  20. X_8:=(CLOSE-REF(CLOSE,8))/REF(CLOSE,8)*100;
  21. X_9:=(CLOSE-REF(CLOSE,9))/REF(CLOSE,9)*100;
  22. X_10:=(CLOSE-REF(CLOSE,10))/REF(CLOSE,10)*100;
  23. X_11:=(CLOSE-REF(CLOSE,11))/REF(CLOSE,11)*100;
  24. X_12:=(CLOSE-REF(CLOSE,12))/REF(CLOSE,12)*100;
  25. X_13:=(CLOSE-REF(CLOSE,13))/REF(CLOSE,13)*100;
  26. X_14:=(CLOSE-REF(CLOSE,14))/REF(CLOSE,14)*100;
  27. X_15:=(CLOSE-REF(CLOSE,15))/REF(CLOSE,15)*100;
  28. X_16:=(CLOSE-REF(CLOSE,16))/REF(CLOSE,16)*100;
  29. X_17:=(CLOSE-REF(CLOSE,17))/REF(CLOSE,17)*100;
  30. X_18:=(CLOSE-REF(CLOSE,18))/REF(CLOSE,18)*100;
  31. X_19:=(CLOSE-REF(CLOSE,19))/REF(CLOSE,19)*100;
  32. X_20:=(CLOSE-REF(CLOSE,20))/REF(CLOSE,20)*100;
  33. X_21:=X_1+X_2+X_3+X_4+X_5;
  34. X_22:=X_1+X_2+X_3+X_4+X_5+X_6+X_7+X_8+X_9+X_10;
  35. X_23:=X_1+X_2+X_3+X_4+X_5+X_6+X_7+X_8+X_9+X_10+X_11+X_12+X_13+X_14+X_15+X_16+X_17+X_18+X_19+X_20;
  36. X_24:=(X_22-X_21*50)/100;
  37. X_25:=(X_23-X_22*100)/100;
  38. X_26:=(X_23-X_21*150)/100;
  39. X_27:=(SUM(X_21,3)*30-MA(SUM(X_21,3),45))/10;
  40. X_28:=(X_22*30-REF(SUM(X_22,3),1))/10;
  41. X_29:=(X_21*30-REF(SUM(X_21,3),1))/10;
  42. X_30:=(CLOSE-REF(CLOSE,1))/REF(CLOSE,1)*100;
  43. X_31:=SUM(X_30,3)*30-MA(SUM(X_30,3),45);
  44. X_32:=X_30*30-REF(SUM(X_30,3),1);
  45. X_33:=(X_28+X_29+X_27+X_31+X_32)/5;
  46. X_34:=SUM(X_32,WEEKDAY)/10;
  47. X_35:=CYHT.高抛#WEEK;
  48. X_36:=MA(X_35,PERIOD)+2*STD(X_35,PERIOD);
  49. X_37:=MA(X_35,3*PERIOD)+2*STD(X_35,3*PERIOD);
  50. X_38:=MA(X_35,5*PERIOD)+2*STD(X_35,5*PERIOD);
  51. X_39:=MA(X_35,6*PERIOD)+2*STD(X_35,6*PERIOD);
  52. X_40:=MA(X_35,7*PERIOD)+2*STD(X_35,7*PERIOD);
  53. X_41:=MA(X_36-REF(X_36,2*PERIOD),PERIOD)+2*STD(X_36-REF(X_36,3*PERIOD),PERIOD);
  54. X_42:=MA(X_37-REF(X_37,2*PERIOD),PERIOD)+2*STD(X_37-REF(X_37,3*PERIOD),PERIOD);
  55. X_43:=MA(X_38-REF(X_38,2*PERIOD),PERIOD)+2*STD(X_38-REF(X_38,3*PERIOD),PERIOD);
  56. X_44:=MA(X_39-REF(X_39,2*PERIOD),PERIOD)+2*STD(X_39-REF(X_39,3*PERIOD),PERIOD);
  57. X_45:=MA(X_40-REF(X_40,2*PERIOD),PERIOD)+2*STD(X_40-REF(X_40,3*PERIOD),PERIOD);
  58. X_46:=REF(HHV(X_38,5),1);
  59. X_47:=REF(HHV(X_38,5),6);
  60. X_48:=REF(HHV(X_38,5),11);
  61. X_49:=REF(HHV(X_38,5),16);
  62. X_50:=REF(HHV(X_38,5),21);
  63. X_51:=REF(HHV(X_38,5),26);
  64. X_52:=IF(X_46<REF(MAX(X_47,X_48),BARSLAST(CROSS(X_38,MAX(X_47,X_48)))),REF(MAX(X_47,X_48),BARSLAST(CROSS(X_38,MAX(X_47,X_48)))),X_46);
  65. X_53:=MA(X_35-REF(X_35,PERIOD),5*PERIOD)+2*STD(X_35-REF(X_35,PERIOD),5*PERIOD);
  66. X_54:=REF(HHV(X_34,5),1);
  67. X_55:=REF(HHV(X_34,5),6);
  68. X_56:=REF(HHV(X_34,5),11);
  69. X_57:=REF(HHV(X_34,5),16);
  70. X_58:=REF(HHV(X_34,5),21);
  71. X_59:=REF(HHV(X_34,5),26);
  72. X_60:=IF(X_54<X_55,X_55,IF(X_55<X_56,X_56,IF(X_56<X_57,X_57,MAX(X_58,X_59))));
  73. X_61:=IF(CROSS(X_34,X_60) AND REF(EXIST(CROSS(X_34,X_60),5),1),X_34,X_60);
  74. X_62:=HHV(X_61,5);
  75. X_63:=IF(X_62<REF(X_62,BARSLAST(CROSS(X_34,X_62))),REF(X_62,BARSLAST(CROSS(X_34,X_62))),X_62);
  76. X_64:=IF(X_54<REF(MAX(X_55,X_56),BARSLAST(CROSS(X_32,MAX(X_55,X_56)))),REF(MAX(X_55,X_56),BARSLAST(CROSS(X_32,MAX(X_55,X_56)))),X_54);
复制代码

游客,如果您要查看本帖隐藏内容请回复




回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则