请选择 进入手机版 | 继续访问电脑版

涨停诀尊赢Y 这个公式看代码都很用心 精细类指标涨停低吸

[复制链接]
mem 发表于 2020-12-6 11:40:03 | 显示全部楼层 |阅读模式
本帖最后由 mem 于 2020-12-6 11:55 编辑
  1. {公式名称: 涨停诀尊赢Y
  2. 公式类型: 技术指标副图公式-选股公式
  3. 公式源码:}

  4. M_1:=REF(COUNT(CLOSE/REF(CLOSE,1)>1.098,5)>0,1) AND NOT(REF(CLOSE,1)/REF(CLOSE,2)<0.96 AND REF(CLOSE,1)/REF(OPEN,1)<0.965 AND REF(CLOSE,1)/REF(LOW,1)>1.05 AND REF(HIGH,1)/REF(OPEN,1)>1.023) AND NOT(REF(CLOSE,2)/REF(CLOSE,3)>1.03 AND REF(OPEN,1)>REF(CLOSE,2) AND REF(CLOSE,1)<REF(LOW,2)) AND NOT(REF(OPEN,2)=REF(HIGH,2) AND REF(CLOSE,2)/REF(CLOSE,3)>1.098 AND REF(OPEN,1)=REF(HIGH,1) AND REF(CLOSE,1)/REF(OPEN,1)<0.98) AND NOT(REF(HIGH,1)/REF(OPEN,1)>1.02 AND REF(CLOSE,1)/REF(LOW,1)>1.02 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,1)/REF(OPEN,1)>0.997);
  5. M_2:=NOT(REF(HIGH,3)/REF(CLOSE,4)>1.098 AND REF(CLOSE,3)<REF(OPEN,3) AND REF(HIGH,3)/REF(OPEN,3)>1.068) AND REF(HHV(HIGH,2),2)/REF(LOW,1)>1.07 AND NOT(REF(CLOSE,2)/REF(CLOSE,3)>1.098 AND REF(OPEN,2)=REF(LOW,2) AND REF(CLOSE,2)=REF(HIGH,2)) AND NOT(REF(OPEN,1)/REF(CLOSE,2)<0.97 AND REF(CLOSE,1)/REF(OPEN,1)<0.98 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(HIGH,1)/REF(OPEN,1)>1.05) AND NOT(REF(COUNT(CLOSE/REF(CLOSE,1)>1.098 AND CLOSE/OPEN>1.03,15)>5,2) AND REF(CLOSE,1)/REF(CLOSE,2)<0.902) AND NOT(REF(OPEN,2)/REF(CLOSE,3)>1.04 AND REF(HIGH,2)/REF(OPEN,2)<1.002 AND REF(CLOSE,2)/REF(OPEN,2)<0.965);
  6. M_3:=NOT(REF(OPEN,2)/REF(CLOSE,3)<1.01 AND REF(HIGH,2)/REF(CLOSE,3)>1.093 AND REF(HIGH,2)/REF(CLOSE,2)>1.04 AND REF(CLOSE,2)/REF(OPEN,2)>1.03) AND REF(COUNT(EVERY(CLOSE/REF(CLOSE,1)>1.098 AND OPEN=CLOSE AND OPEN=HIGH,3),5)=0,1);

  7. M_4:=NOT(REF(OPEN,2)/REF(CLOSE,3)>1.02 AND REF(HIGH,2)/REF(CLOSE,3)>1.096 AND REF(CLOSE,2)<REF(OPEN,2)) AND NOT(REF(HIGH,2)/REF(CLOSE,3)>1.098 AND REF(HIGH,2)/REF(CLOSE,2)>1.015 AND REF(CLOSE,2)/REF(CLOSE,3)>1.08) AND REF(CLOSE,1)/REF(CLOSE,2)<0.992 AND REF(MA(CLOSE,5)>MA(CLOSE,20),1) AND REF(OPEN,2)/REF(CLOSE,1)<1.14 AND OPEN<REF(MAX(CLOSE,OPEN),1) AND OPEN/REF(CLOSE,1)<1.006 AND NOT(REF(OPEN,2)=REF(HIGH,2) AND REF(OPEN,2)>REF(CLOSE,3) AND REF(CLOSE,2)<REF(CLOSE,3));
  8. M_5:=NOT(REF(OPEN,3)=REF(HIGH,3) AND REF(OPEN,3)>REF(CLOSE,4) AND REF(CLOSE,3)<REF(CLOSE,4)) AND REF(CLOSE,2)/REF(CLOSE,3)>0.93 AND REF(CLOSE,1)/REF(OPEN,1)>0.935 AND REF(CLOSE,1)<REF(CLOSE,2) AND NOT(REF(HHV(MAX(CLOSE,OPEN),2),1)/REF(MIN(CLOSE,OPEN),1)<1.04 AND REF(CLOSE,2)/REF(CLOSE,3)>0.97) AND CLOSE/REF(CLOSE,1)>1.02;
  9. M_6:=NOT(REF(OPEN,3)/REF(CLOSE,4)>1.04 AND REF(OPEN,3)/REF(LOW,3)>1.045 AND REF(HIGH,3)/REF(CLOSE,3)>1.0295 AND REF(CLOSE,3)>REF(OPEN,3)) AND NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.098 AND REF(OPEN,3)<REF(OPEN,4) AND REF(CLOSE,3)/REF(CLOSE,4)>1.04 AND REF(HIGH,3)/REF(CLOSE,3)>1.03) AND NOT(REF(OPEN,2)/REF(CLOSE,3)>1.02 AND REF(OPEN,2)=REF(HIGH,2) AND REF(CLOSE,2)/REF(OPEN,2)<0.99);
  10. M_7:=NOT(REF(CLOSE,2)/REF(CLOSE,3)<0.99 AND REF(CLOSE,1)/REF(CLOSE,2)<0.902 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,1)/REF(OPEN,1)>0.999) AND NOT(REF(CLOSE,2)/REF(CLOSE,3)>1.05 AND REF(CLOSE,3)/REF(CLOSE,4)>1.098 AND REF(OPEN,2)/REF(LOW,2)>REF(HIGH,2)/REF(CLOSE,2) AND REF(CLOSE,2)>REF(OPEN,2) AND REF(HIGH,2)/REF(CLOSE,2)>1.02 AND REF(OPEN,2)/REF(LOW,2)>1.02);
  11. M_8:=CAPITAL<10000000 AND NOT(REF(CLOSE,4)=REF(OPEN,4) AND REF(CLOSE,4)/REF(CLOSE,5)>1.098 AND REF(OPEN,3)/REF(CLOSE,4)>1.07 AND REF(CLOSE,3)/REF(OPEN,3)<0.96 AND REF(CLOSE,3)>REF(CLOSE,4)) AND NOT(REF(CLOSE,4)/REF(CLOSE,5)>1.098 AND REF(CLOSE,3)/REF(OPEN,3)<0.915) AND REF(COUNT(REF(CLOSE,1)/REF(CLOSE,2)>1.098 AND REF(OPEN=CLOSE,1) AND OPEN>REF(CLOSE,1) AND LOW<REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)<1.02 AND CLOSE>REF(CLOSE,1),5)=0,1) AND REF(HHV(CLOSE,4)/CLOSE<1.2,1) AND REF(CLOSE,3)/REF(CLOSE,4)>0.91 AND NOT(REF(OPEN,1)/REF(CLOSE,2)<0.99 AND REF(CLOSE<OPEN AND HIGH/OPEN>1.035,1)) AND NOT(REF(CLOSE/REF(CLOSE,1)<0.902 AND OPEN/CLOSE>1.05,1));

  12. M_9:=REF(COUNT(REF(CLOSE,1)/REF(CLOSE,2)>1.098 AND REF(CLOSE,1)/REF(CLOSE,2)>1.05 AND (HIGH/CLOSE>1.029 AND OPEN>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)>1.029 AND CLOSE/REF(CLOSE,1)<1.0575 AND VOL/REF(VOL,1)>1.2 OR (OPEN>REF(CLOSE,1) AND LOW<REF(CLOSE,1) AND CLOSE>REF(CLOSE,1) AND CLOSE/REF(CLOSE,1)<1.013) OR (HIGH/OPEN<1.003 AND OPEN/REF(CLOSE,1)>1.02 AND CLOSE<OPEN) OR (CLOSE<REF(CLOSE,1) AND OPEN<REF(CLOSE,1) AND CLOSE<OPEN AND CLOSE/LOW>1.03) OR (OPEN/REF(CLOSE,1)<0.96 AND OPEN/CLOSE>1.04)),4)=0,1);
  13. M_10:=M_8 AND M_9;
  14. M_11:=REF(CLOSE,2)/REF(CLOSE,3)>1.098 AND NOT(REF(OPEN,1)/REF(CLOSE,1)<1.15 AND REF(OPEN,1)=REF(HIGH,1)) AND NOT(REF(CLOSE,5)/REF(CLOSE,6)>1.098 AND REF(CLOSE,5)/REF(OPEN,5)>1.05) AND REF(CLOSE,2)/REF(OPEN,2)>1.08 AND NOT(REF(MA(CLOSE,120),1)/REF(MA(CLOSE,120),2)<1.001 AND REF(OPEN,1)<REF(MA(CLOSE,120),1)) AND REF(OPEN,1)/REF(CLOSE,2)>1.018 AND REF(CLOSE,2)/REF(CLOSE,5)<1.15 AND REF(COUNT(CLOSE/REF(CLOSE,1)>1.098,3)<2,2) AND REF(CLOSE,1)/REF(CLOSE,2)<0.975 AND OPEN/REF(CLOSE,1)<0.975 AND CLOSE/REF(CLOSE,1)>1.02;
  15. M_12:=REF(COUNT(CLOSE/REF(CLOSE,1)>1.098,3)>0,1) AND REF(HIGH,1)/REF(OPEN,1)>1.04 AND REF(OPEN,1)/REF(CLOSE,2)<0.995 AND REF(CLOSE,1)<REF(OPEN,1) AND REF(CLOSE,1)/REF(OPEN,1)>0.99 AND REF(CLOSE,1)/REF(CLOSE,2)>0.96 AND REF(MA(CLOSE,5)>MA(CLOSE,10) AND MA(CLOSE,10)>MA(CLOSE,20) AND MA(CLOSE,20)>MA(CLOSE,60) AND LOW/MA(CLOSE,20)<1.1 AND MA(CLOSE,20)/MA(CLOSE,60)<1.1,1) AND OPEN/REF(CLOSE,1)<0.985 AND CLOSE/REF(CLOSE,1)>1.02;
  16. M_13:=M_11 OR M_12;
  17. M_14:=NOT(NAMELIKE(1) OR NAMELIKE(2));
  18. M_15:=REF(HIGH,2)/REF(CLOSE,3)>1.035 AND NOT(REF(CLOSE>OPEN AND HIGH/CLOSE>1.04,2)) AND REF(MA(CLOSE,4)>MA(CLOSE,13),1) AND REF(CLOSE,1)/REF(OPEN,1)>0.908 AND REF(COUNT(CLOSE/REF(CLOSE,1)>1.09 AND HIGH/REF(CLOSE,1)>1.098,8)<3,2) AND NOT(REF(OPEN,2)=REF(HIGH,2) AND REF(OPEN,2)/REF(CLOSE,3)>1.098 AND REF(CLOSE,2)/REF(OPEN,2)<0.985);
  19. M_16:=NOT(REF(CLOSE,1)<REF(MA(CLOSE,20),1) AND REF(CLOSE,1)/REF(MA(CLOSE,60),1)>1.05) AND OPEN/REF(CLOSE,1)<1.012 AND REF(COUNT(HIGH/REF(CLOSE,1)>1.09 AND CLOSE/REF(CLOSE,1)>1.05,50)>0,1) AND NOT(REF(CLOSE,3)=REF(OPEN,3)) AND REF(OPEN,1)<REF(CLOSE,2) AND REF(MA(CLOSE,20)>MA(CLOSE,60),1) AND REF(OPEN,1)=REF(HIGH,1) AND REF(CLOSE,1)/REF(OPEN,1)<0.965 AND CLOSE/REF(CLOSE,1)>1.02;
  20. M_17:=M_15 AND M_16 AND M_14 AND BARSCOUNT(CLOSE)>60;
  21. M_18:=REF(CLOSE,2)/REF(CLOSE,3)>1.098 AND REF(CLOSE,2)/REF(OPEN,2)>1.05 AND REF(OPEN,1)/REF(CLOSE,2)>1.02 AND REF(CLOSE,1)/REF(CLOSE,2)<0.985 AND REF(CLOSE,1)/REF(OPEN,1)<0.97 AND REF(HIGH,1)/REF(OPEN,1)>1.01 AND OPEN/REF(CLOSE,1)<0.995 AND CLOSE/REF(CLOSE,1)>1.02 AND NOT(REF(EVERY(CLOSE/REF(CLOSE,1)>1.03,2),3)) AND OPEN/LOW<1.004;
复制代码

游客,如果您要查看本帖隐藏内容请回复


配合公式涨停诀预选http://iyaogu.cn/forum.php?mod=v ... =1&extra=#pid112399

公式只对过去历史K线的展示,不代表未来具有同样的成功率。
股市不确定性较大,一切买卖和盈亏与指标无关~风险自负!



回复

使用道具 举报

股代夜不收 发表于 2021-5-15 12:57:23 | 显示全部楼层
谢分享
回复

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则